Technical Help

Progressive's site is optimized for most modern browsers (desktop, tablet and mobile). Just make sure to:

  • Update your browser: We support the latest versions of Chrome, Firefox, Safari, Internet Explorer and Edge.
  • Enable Javascript: You'll need this to get your quote.
  • Accept cookies: You'll have a more personalized experience, and you can save certain information (like your policy ID) for future visits.
  • Download the latest Adobe Reader: You'll have an easier time getting forms and documents.

Updating your browser for security standards

Some older browsers may be using the Transport Layer Security (TLS) version 1.0 encryption protocol. TLS v1.0 is an outdated protocol and no longer meets Progressive’s minimum required security standards; TLS v1.2 is considered the most secure protocol supported by browsers today.

As of April 2018, Progressive will only support browsers with TLS v1.1 or greater enabled. If your browser does not support the TLS v1.1 encryption protocol or greater, you will not be able to view or access Progressive.com; therefore it is very important to take action now to ensure your browser supports TLS v1.1 or greater.

How to enable TLS v1.1 or greater

The easiest solution is to upgrade your browser. If you use the latest version of Chrome, Firefox, Safari, Internet Explorer and Edge you’ll already meet our security standards and won’t need to do anything else.

But, if you use Internet Explorer 8, 9 or 10 (and do not want to or can't update to a newer browser) you may be able to follow these steps to update your browser security settings:

  1. Open the "Tools" menu in Internet Explorer. (Gear icon in the upper right corner of your window)
  2. Click "Internet Options" and then click the "Advanced" tab
  3. Scroll to the "Security" section and then manually check the option boxes that mention "Use TLS 1.1" and “Use TLS 1.2”
  4. Click OK, then restart your browser
;